vscode

Las quejas han surtido efecto y, tras conocerse que la nueva versión de Visual Studio Code dejaba sin soporte a «distribuciones Linux viejas», los responsables del proyecto lo han reconsiderado y el ampliarán el soporte durante un año más para dar tiempo a que todo el mundo pueda dar el salto o considerar otras opciones.

Nos hicimos eco de la noticia hace un par de semanas y como contamos entonces el lanzamiento mensual del editor de código multiplataforma de Microsoft aparecía con un cambio importante en sus requisitos que afectaba directamente a la compilación de la aplicación en Linux. En concreto, la nueva versión tomaba como requisito versiones más recientes de glibc con la consecuencia de dejar atrás todo lo que dependiera de ellas.

Así, distribuciones como Debian 9, Red Hat Enterprise Linux 7 y Ubuntu 16.04 LTS se quedaban sin soporte de Visual Studio Code 1.86; distribuciones con un buen número de años a sus espaldas, lo cual puede generar dudas sobre quién se queja de algo así. Y la respuesta es, principalmente, desarrolladores que todavía utilizan estas versiones en servidores, aunque de todo habrá un poco.

Sea como fuere, la actualización llegó y los usuarios afectados se quedaron con dos palmos de narices, o con dos posibles opciones, que en realidad son tres: actualizar el sistema o seguir utilizando una versión desactualizada de VSCode. También existía la posibilidad de adoptar una alternativa, que las hay, pero… No va a ser necesario.

A una petición de apaño temporal, el desarrollador de Visual Studio Code Isidor Nikolic respondía en positivo, asegurando que mantendrán el soporte del editor por un año más en todos los sistemas afectados. ¿Cómo lo harán, o mejor dicho, cómo lo han hecho? Lanzando una nueva actualización con dicho cambio ya implementado.

«Esperamos que esto proporcione el tiempo necesario para que vosotros y vuestras empresas migren a distribuciones de Linux más nuevas. El código VS mostrará el cuadro de diálogo y el banner apropiados que está conectando a un sistema operativo que no es compatible con el código VS», explica Nikolic.

A todo esto, VSCode 1.86 ha sido un lanzamiento con novedades bastante interesantes, según se recoge en las notas de lanzamiento oficiales.

 

Fuente: muylinux

¿Quién está en línea?

Hay 24674 invitados y ningún miembro en línea