vscode

Hace un par de días que se anunció el lanzamiento de Visual Studio Code 1.86, la versión mensual del editor de código multiplataforma de Microsoft. Se trata de una de las aplicaciones más populares de su categoría, por lo que sobran más presentaciones, como sobra decir que, como siempre, lo hizo con un buen número de novedades en su haber. Otra cosa no, pero nadie puede negar el nivel de desarrollo de este proyecto.

Sin embargo, VSCode 1.86 no llega solo con un montón de novedades en la forma de añadidos; también se quita algo de lastre de encima, aunque no todo el mundo lo está viendo de este modo. En concreto esta nueva versión toma como requisito en Linux dependencias como glibc 2.28 y glibcxx 3.4.25 o versiones superiores, con las consiguientes consecuencias: distribuciones como Debian 9, Red Hat Enterprise Linux 7 y Ubuntu 18.04 LTS se quedan sin soporte.

O lo que es lo mismo, solo los usuarios de Debian 10, RHEL 8 y Ubuntu 20.04 LTS podrán instalar VSCode 1.86 (y los de cualquier otra distribución que cumpla con los requisitos, se entiende). Algo que ya está generando quejas, según recogen en OMG! Ubuntu! Un problema con dos vías de solución: aguantar utilizando VSCode 1.85 hasta actualizar el sistema u, obviamente, actualizar el sistema a una versión con soporte.

Però ¿tiene todo esto sentido? Al parecer sí, y es que las quejas provienen principalmente por parte de desarrolladores trabajando en servidores que no pueden actualizar de un día para otro. En estos casos, pero también en los más improbables de tratarse de usuarios de escritorio, Microsoft ha publicado estas instrucciones, aunque como se ha señalado, no hay mucho que hacer (las instrucciones explican cómo volver a la versión anterior del IDE).

Por lo demás cuesta encontrar razones por las que cualquier usuario de escritorio no haya actualizado todavía a Debian 10 o RHEL 8, versiones lanzadas a mediados de 2019. O sea, hace casi cinco años. Ubuntu 18.04 LTS, por su parte, se lanzó un año antes, en abril de 2018, por lo que el tiempo ha corrido un poco más para ella.

Sin ir más lejos, el soporte extendido de Bionic Beaver finalizó en mayo de 2023 en mayo de 2023, si bien sigue con mantenimiento gracias al soporte añadido proporcionado por Ubuntu Pro y que se alargará como mínimo hasta 2028, aunque lo más probable es que lo haga hasta 2030 si se aplica la última ampliación del soporte, anunciada hace apenas un par de semanas.

¿Quien aguanta tanto tiempo en un sistema tan viejo ya no en un servidor, sino en una estación de trabajo? Como se suele decir, de todo hay en la viña del señor. Aunque como también se suele decir, hay veces en las que solo queda renovarse o morir.

 

Fuente: muylinux

¿Quién está en línea?

Hay 17528 invitados y ningún miembro en línea