Librem-5-Linux-smartphone

El mes pasado, Purism anunció que su smartphone Librem 5 con Linux se enviará en abril de 2019; antes, estaba previsto que llegara en enero de 2019.

Parece que los desarrolladores tendrán tiempo suficiente para enviar el teléfono con GNOME 3.32. En una entrada de blog, el proyecto instaba a los desarrolladores de aplicaciones a “usar libhandy 0.0.4 y superior, usar GTK+ 3.24.1 y superior y apuntar a GNOME 3.32”.

Con la ayuda de las nuevas características añadidas a las correcciones de libhandy y GTK+, los desarrolladores pueden hacer que sus aplicaciones se adapten tanto al escritorio como al dispositivo móvil Librem 5 que funciona con GNOME.

El post también menciona que muchas aplicaciones como Calls, Chatty, Fractal, y Podcasts ya están usando estas capacidades de adaptación; también se está haciendo un trabajo similar para Settings, Games, Contacts, y Geary.

Actualmente, una biblioteca de widgets de GTK+3, libhandy y widgets relevantes serán pronto portados a GTK+ 4.

Según la página oficial:

Estamos al principio del programa de lanzamiento de GNOME 3.32 y Librem 5 será lanzado un poco después, así que si quiere que sus aplicaciones trabajen en Librem 5, ahora es el mejor momento: ¡usaremos libhandy 0.0.4 y superior, GTK+ 3.24.1 y superior y apuntaremos a GNOME 3.32! Algunas aplicaciones como Fractal, Podcasts, Calls y Chatty ya están usando las capacidades adaptativas de libhandy, y otras aplicaciones están trabajando en su transición adaptativa como Contactos, Juegos, Geary y Configuración (todas están en proceso). Libhandy está disponible en Debian Unstable y en el repositorio AUR de Arch, y desearía que ya estuviera en Fedora para dejar pasar el CI de los ajustes de GNOME.

 

Fuente: maslinux

¿Quién está en línea?

Hay 48986 invitados y ningún miembro en línea