amazon

El equipo de Amazon Elastic Kubernetes Service (EKS) anunció la compatibilidad con Kubernetes 1.22. Esta versión de Kubernetes, lanzada en agosto de 2021, viene con complementos de credenciales estables, aplicación del lado del servidor, mejoras relacionadas con Windows y funciones de seguridad en el plano de control de Kubernetes.

El lanzamiento 1.22 fue el primer lanzamiento de ciclo más largo después de que la cadencia de lanzamiento cambiara de 4 a 3 por año. Esta versión tenía 53 mejoras, de las cuales 13 se movieron a estable. Varias API beta fueron reemplazadas con sus versiones GA. El conjunto de características de complementos de credenciales se movió a estable. Los complementos de credenciales permiten la integración de la biblioteca cliente de Kubernetes y las herramientas que la usan con protocolos de autenticación que la biblioteca no admite de forma nativa. Estas herramientas incluyen kubectl y kubelet. La versión estable brinda soporte mejorado para flujos de inicio de sesión interactivos para dichos complementos.

Otra característica importante que pasó a GA en 1.22 fue la aplicación del lado del servidor. El blog oficial de Kubernetes señala que "La aplicación del lado del servidor reemplaza la función de aplicación del lado del cliente implementada por 'kubectl apply' con una implementación del lado del servidor, lo que permite el uso de herramientas/clientes que no sean kubectl". También hay mejoras relacionadas con Windows y características de seguridad en el plano de control de Kubernetes.

El almacén de objetos subyacente de Kubernetes, etc., se trasladó a 3.5.0 en esta versión, con mejoras en la seguridad, el rendimiento y la supervisión. El anuncio de EKS explica que "en el proceso de lanzamiento de Amazon EKS 1.22, la intención era enviar la última y mejor versión de etcd, 3.5.2 (que se recomienda para Kubernetes 1.22)". Sin embargo, el lanzamiento inicial de Amazon EKS 1.22 utiliza etcd v3.4 como backend para evitar algunos problemas de coherencia de datos en las versiones más recientes.

Amazon EKS también dejará de admitir Dockershim. La mayoría de los principales proveedores de servicios de Kubernetes están haciendo esto después de que el proyecto central de Kubernetes lo anunciara como parte del paso al uso de implementaciones estandarizadas. Los esfuerzos de estandarización para definir las interfaces entre el agente de Kubernetes (kubelet) y el tiempo de ejecución del contenedor culminaron en la interfaz de tiempo de ejecución del contenedor (CRI). containerd y CRI-O son tiempos de ejecución alternativos disponibles en lugar de Dockershim, con EKS y GKE usando containerd como valor predeterminado. El equipo de EKS planea eliminar la compatibilidad con Dockershim en la próxima versión principal (1.23). Han proporcionado una herramienta para detectar el uso del socket Docker (un indicador de que el demonio Docker se está ejecutando) para facilitar la transición.

Como parte de este anuncio, EKS también incluye 1.22 en EKS Anywhere y Amazon EKS Distro, que permite a los usuarios ejecutar clústeres de Kubernetes en las instalaciones de su propia nube o centros de datos.

Los proveedores de Kubernetes administrados generalmente agregan soporte para una versión estable de Kubernetes mientras mantienen las últimas versiones anteriores . GKE presentó 1.22 en octubre y Azure Kubernetes Service en diciembre del año pasado. Es la última versión estable disponible en GKE. Esta versión de Kubernetes también es compatible con OpenShift Container Platform 4.9 de RedHat.

 

Fuente: infoq | somoslibres

¿Quién está en línea?

Hay 33538 invitados y ningún miembro en línea