Jueves, Diciembre 02, 2021

Fueron encontradas vulnerabilidades en la mayoría de los clientes de Matrix

vulnerabilidad

Hace poco se dio a conocer la noticia de que fueron identificadas vulnerabilidades (CVE-2021-40823, CVE-2021-40824) en la mayoría de aplicaciones cliente para la plataforma de comunicaciones descentralizadas Matrix, las cuales permiten obtener información sobre las claves utilizadas para transferir mensajes en chats cifrados de extremo a extremo (E2EE).

Un atacante que haya comprometido a uno de los usuarios del chat puede descifrar los mensajes enviados previamente a este usuario desde aplicaciones cliente vulnerables. La operación exitosa requiere acceso a la cuenta del destinatario del mensaje y el acceso se puede obtener tanto a través de una filtración de los parámetros de la cuenta como mediante la piratería del servidor Matrix a través del cual el usuario se conecta.

Se menciona que las vulnerabilidades son más peligrosas para los usuarios de salas de chat cifradas a las que están conectados los servidores Matrix controlados por los atacantes. Los administradores de dichos servidores pueden intentar hacerse pasar por usuarios del servidor para interceptar los mensajes enviados al chat desde aplicaciones cliente vulnerables.

Las vulnerabilidades son causadas por errores lógicos en las implementaciones del mecanismo para otorgar re-acceso a claves propuestas en los diferentes clientes detectados. Las implementaciones basadas en las bibliotecas matrix-ios-sdk , matrix-nio y libolm no son vulnerables a vulnerabilidades.

En consecuencia, las vulnerabilidades aparecen en todas las aplicaciones que tomaron prestado el código problemático y no afectan directamente a los protocolos Matrix y Olm/Megolm.

Específicamente, el problema afecta al cliente principal Element Matrix (anteriormente Riot) para la Web, el escritorio y Android, así como a las aplicaciones y bibliotecas de clientes de terceros, como FluffyChat , Nheko , Cinny y SchildiChat . El problema no aparece en el cliente oficial de iOS, ni en las aplicaciones Chatty, Hydrogen, mautrix, purple-matrix y Siphon.

Las versiones parcheadas de los clientes afectados ya están disponibles; por lo que se pide que se actualice lo antes posible y pedimos disculpas por las molestias. Si no puede actualizar, considere mantener a los clientes vulnerables fuera de línea hasta que pueda. Si los clientes vulnerables están desconectados, no se les puede engañar para que revelen las claves. Es posible que vuelvan a estar en línea de forma segura una vez que se actualicen.

Desafortunadamente, es difícil o imposible identificar retroactivamente instancias de este ataque con niveles de registro estándar presentes tanto en clientes como en servidores. Sin embargo, dado que el ataque requiere comprometer la cuenta, los administradores del servidor doméstico pueden desear revisar sus registros de autenticación para detectar cualquier indicio de acceso inapropiado.

El mecanismo de intercambio de claves, en cuya implementación se encontraron las vulnerabilidades, permite a un cliente que no tiene las claves descifrar un mensaje para solicitar claves desde el dispositivo del remitente u otros dispositivos.

Por ejemplo, esta capacidad es necesaria para garantizar el descifrado de mensajes antiguos en el nuevo dispositivo del usuario o en el caso de que el usuario pierda las claves existentes. La especificación del protocolo prescribe de forma predeterminada no responder a las solicitudes de claves y enviarlas automáticamente solo a los dispositivos verificados del mismo usuario. Desafortunadamente, en implementaciones prácticas, este requisito no se cumplió y las solicitudes para enviar claves se procesaron sin la identificación adecuada del dispositivo.

Las vulnerabilidades se identificaron durante una auditoría de seguridad del cliente Element. Actualmente, las correcciones ya están disponibles para todos los clientes con problemas. Se recomienda a los usuarios que instalen urgentemente las actualizaciones y desconecten a los clientes antes de instalar la actualización.

No hubo evidencia de explotación de la vulnerabilidad antes de la publicación de la revisión. Es imposible determinar el hecho de un ataque mediante los registros estándar del cliente y el servidor, pero dado que el ataque requiere comprometer la cuenta, los administradores pueden analizar la presencia de inicios de sesión sospechosos mediante los registros de autenticación en sus servidores, y los usuarios pueden evaluar la lista de dispositivos vinculados a su cuenta para reconexiones recientes y cambios de estado de confianza.

 

Fuente: matrix.org | desdelinux

¿Quién está en línea?

Hay 153 invitados y ningún miembro en línea

Contador de Visitas

12597786
Hoy Hoy 1572
Ayer Ayer 4707
Esta semana Esta semana 15078
Este mes Este mes 6279
Total de Visitas Total de Visitas 12597786

Día con más
visitantes

11-10-2021 : 5280

Gracias por su visita