Lunes, Julio 24, 2017

Solventar problemas de errores de firmas GPG en Ubuntu

603/20460300159_6337b80b80_z.jpg

En algunas ocasiones Ubuntu nos muestra un error de tipo “W: Error de GPG: http://ppa.launchpad.net trusty Release: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 0F678A01569113AE” cuando actualizamos los repositorios vía terminal y en algunos casos, es causa de avisos “molestos” de error al iniciar el sistema, pues bien esto es debido principalmente a problemas relacionados con llaves GPG de aplicaciones, si este es tu caso, te muestro una solución a ello (al menos en mi caso funcionó)

Luego de haber pasado unas pseudo-vacaciones en el “lado oscuro” (cof, cof, Windows) ya que poseo una partición con el sistema operativo de las ventanas y pues actualice a su tan anunciada versión 10, retorne nuevamente a mi querido Ubuntu pero decidí reinstalarlo de cero nuevamente, pues la actualización del anterior sistema mencionado borró el GRUB para instalar su propio arranque y además de esto, pues si se estrena nuevo sistema en una partición, porque no “estrenar nuevamente” mi querido Ubuntu en esta partición…. Pues bien yendo al tema, luego de actualizar el sistema, agregar la nueva y excelente PPA que recién lanzaron un grupo de desarrolladores de Ubuntu (ya hablaré de esto en otro tema) y otras PPA’s mas (libreoffice, gimp, multimedia, shotwell, quiterss, smplayer, psensor, caffeine y el de mozilla) al reiniciar el pc e instalar la PPA de Wine Staging (voy a probarlo a ver que tal ;) ) justo cuando ejecuto el comando de actualización de repositorios (sudo apt-get update) me encuentro con la sorpresa de que finalizando el proceso me salta el error “W: Error de GPG: http://ppa.launchpad.net trusty Release: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 0F678A01569113AE” con el cuadro gráfico típico de error, pues bien, luego de indagar brevemente en la internet me encuentro con la solución del problema la cuál es la siguiente:

– Copiamos los ocho últimos números de la llave pública que no se encontró, en mi caso es “569113AE”
– En la terminal colocamos: gpg –keyserver keyserver.ubuntu.com –recv-keys 569113AE (aquí es donde colocas esos ocho números de la llave pública no encontrada)
– Luego nos saldrá algo como esto:

gpg: /home/rmarquez/.gnupg: directorio creado
gpg: creado un nuevo archivo de configuración `/home/rmarquez/.gnupg/gpg.conf’
gpg: AVISO: las opciones en `/home/rmarquez/.gnupg/gpg.conf’ no están aún activas en esta ejecución
gpg: anillo «/home/rmarquez/.gnupg/secring.gpg» creado
gpg: anillo «/home/rmarquez/.gnupg/pubring.gpg» creado
gpg: solicitando clave 569113AE de hkp servidor keyserver.ubuntu.com
gpg: /home/rmarquez/.gnupg/trustdb.gpg: se ha creado base de datos de confianza
gpg: clave 569113AE: clave pública “Launchpad Caffeine” importada
gpg: Cantidad total procesada: 1
gpg: importadas: 1 (RSA: 1)

– Luego colocamos gpg –export –armor 569113AE | sudo apt-key add – (no pongo énfasis en el número ya que este variará, obviamente ahí se vuelve a colocar los ocho números que se indicó al inicio)
– Y el sistema nos dirá Ok

Finalmente volvemos a actualizar los repositorios y ya no nos debería aparecer ese error!

 

Fuente: libuntu

Compártelo. ¡Gracias!

 
Grupo Digital de Ayuda! Laboratorio Linux! - Linux para todos.

¿Quién está en línea?

Hay 23 invitados y ningún miembro en línea

Contador de Visitas

8899906
Hoy Hoy 210
Ayer Ayer 1030
Esta semana Esta semana 210
Este mes Este mes 28115
Total de Visitas Total de Visitas 8899906

Día con más
visitantes

07-19-2017 : 1525

Gracias por su visita