Jueves, Julio 18, 2019

Es muy importante que parchees VIM si no lo has hecho

vim

Una vulnerabilidad recientemente parcheada en los editores de texto preinstalada en todas las distribuciones de GNU/Linux permite a los hackers tomar el control de los ordenadores cuando los usuarios abren un archivo de texto malicioso. La última versión de macOS de Apple sigue utilizando una versión vulnerable, aunque los ataques sólo funcionan cuando los usuarios han cambiado una configuración predeterminada que habilita una función llamada modelines.

Vim y su derivado bifurcado, NeoVim, contenían un defecto que residía en modelines. Esta función permite a los usuarios especificar las dimensiones de las ventanas y otras opciones personalizadas cerca del inicio o del final de un archivo de texto. Mientras que modelines restringe los comandos disponibles y los ejecuta dentro de una sandbox que está incluida con el sistema operativo, el investigador Armin Razmjou notó que el comando source! pasó por alto esa protección.

“Lee y ejecuta comandos de un archivo dado como si se hubieran escrito manualmente, ejecutándolos después de que se haya saltado el sandox”, escribió el investigador en un post a principios de este mes.

El post incluye dos archivos de texto de prueba de concepto que demuestran gráficamente la amenaza. Uno de ellos abre un shell inverso en el ordenador que ejecuta Vim o NeoVim. Desde allí, los atacantes podían canalizar comandos de su elección a la máquina requisada.

“Este PoC describe un enfoque de ataque de la vida real en el que se lanza un shell inverso una vez que el usuario abre el archivo”, escribió Razmjou. “Para ocultar el ataque, el archivo se reescribirá inmediatamente cuando se abra. Además, el PoC utiliza secuencias de escape de terminal para ocultar la línea modelo cuando el contenido se imprime con cat. (cat -v revela el contenido real.)”

El investigador incluyó la siguiente imagen GIF:

modelines-poc

La vulnerabilidad de ejecución de comandos requiere que la función de modelines estándar esté habilitada, como ocurre en algunas distribuciones GNU/Linux de forma predeterminada. El defecto reside en Vim antes de la versión 8.1.1365 y en Neovim antes de la versión 0.3.6. Este aviso del National Institute of Standards and Technology’s National Vulnerabilities Database muestra que tanto las distribuciones Debian como Fedora han comenzado a publicar versiones parcheadas. Los usuarios de GNU/Linux deben asegurarse de que la actualización se instale, especialmente si tienen el hábito de usar uno de los editores de texto afectados.

Curiosamente, macOS de Apple, que viene con Vim desde hace mucho tiempo, sigue ofreciendo una versión 8 vulnerable del editor de texto. Modelines no está habilitado por defecto, pero en el caso de que un usuario lo active, existe la amenaza. Si tu distribución GNU/Linux aún no ha parcheado Vim y Neovim, sería buena idea que utilizaras otro editor, como Nano.

 

Fuente: maslinux

¿Quién está en línea?

Hay 120 invitados y ningún miembro en línea

Contador de Visitas

9851759
Hoy Hoy 1257
Ayer Ayer 2171
Esta semana Esta semana 7923
Este mes Este mes 38461
Total de Visitas Total de Visitas 9851759

Día con más
visitantes

06-04-2019 : 2722

Gracias por su visita