Martes, Abril 23, 2019

Canonical lanza importante actualización del kernel para Ubuntu 16.04

Unity-Ubuntu

Los fallos de seguridad en Linux suelen ser pocos y no demasiado graves, pero el parche que acaba de lanzar Canonical demuestra que no siempre es así. La compañía que dirige Mark Shuttleworth ha lanzado una actualización del kernel de Ubuntu 16.04 LTS (Xenial Xerus) que corrige hasta cinco fallos descubiertos por varios investigadores de seguridad en el kernel 4.4, un núcleo que está presente en el sistema operativo que Canonical lanzó hace 3 años, en abril de 2016. También están afectadas todas las versiones basadas en Ubuntu que usen el mismo kernel.

La solución ya está presente en el Linux 4.15 HWE que incluye Ubuntu 18.04 LTS, por lo que otras versiones de ciclo de vida de 9 meses, es decir, no LTS también parecen estar afectadas. El caso es que Canonical sólo ha puesto esta actualización a disposición de los usuarios cuyo sistema operativo esté comprometido y que aún disfrute de soporte oficial. Ubuntu 14.04 disfrutará de soporte hasta el próximo 30 de abril pero su kernel no está afectado por los 5 fallos mencionados en este artículo.

La actualización del Kernel de Ubuntu 16.04 corrige 5 fallos de seguridad

Los cinco fallos que se han corregido son:

  • El CVE-2017-18241: fallo en la implementación del sistema de archivos F2FS  que gestionaba incorrectamente la opción de montaje noflush_merge.
  • CVE-2018-7740: relacionado con el error anterior, pero en este caso en múltiples sobrecargas en la implementación hugetlbfs. Este y el error anterior podrían permitir a un usuario malintencionado local explotar la vulnerabilidad a través de la denegación de servicio.
  • El CVE-2018-1120 se descubrió en el sistema de archivos procfs y permitía a un usuario malintencionado local bloquear ciertas herramientas usadas para examinar el sistema de archivos procfs para reportar el estado del sistema operativo debido a que fallaba al gestionar correctamente los procesos de mapeado en los elementos de la memoria.
  • CVE-2019-6133 permitía a un usuario malintencionado local conseguir acceso a servicios que almacenaban autorizaciones.
  • CVE-2018-19985 podría permitir que un atacante físicamente cercano causara un fallo del sistema.

Canonical recomienda a todos los usuarios afectados actualizar tan pronto en cuanto les sea posible a la versión del kernel 4.4 que ya está disponible en los repositorios oficiales. Personalmente, teniendo en cuenta que todos los fallos deberían ser explotados por un atacante local, yo sí, actualizaría pronto, pero tampoco me preocuparía demasiado. ¿Y tú?

 

Fuente: ubunlog

¿Quién está en línea?

Hay 112 invitados y ningún miembro en línea

Contador de Visitas

9682600
Hoy Hoy 1135
Ayer Ayer 1581
Esta semana Esta semana 2716
Este mes Este mes 41076
Total de Visitas Total de Visitas 9682600

Día con más
visitantes

03-20-2019 : 2228

Gracias por su visita